Patched Channels

f0urtyfive
Site Admin
Posts: 35
Joined: Sun Jul 08, 2012 1:50 am

Re: Patched Channels

Post by f0urtyfive » Sat Oct 24, 2015 7:29 pm

So, judging by the comment data, that was actually 4 talkgroups patched at once, 577, 1706, 579, and 529 do you have two of those groups added to your profile?

In EDACS, it "creates" a new talk group in the patch range, and then announces each individual talkgroup that is patched (So, 577, 1706, 579 and 529 would all be "logically" patched to Patch TG #1) then all radio traffic goes to that new patch TG. The way it works on the radio side at the moment is that the controller maintains a list of "active" patches, and staples them on to any transmission that ends while the patch is active. Then on the upload side, it basically just copy pastes a copy into each of the patched TGs.

If thats where the problem is coming from (IE, it's playing back twice because you're listening to two talkgroups that are both in the same patch) it's going to be pretty tricky to fix, and I'll probably need to rewrite that functionality so that it stores 1 unique call, and then somehow virtually links it to each TG.

jbeen
Posts: 11
Joined: Fri Jul 03, 2015 2:54 am

Re: Patched Channels

Post by jbeen » Sun Oct 25, 2015 1:28 am

Thanks for the further info about patching on the EDACS system.

Looks like the 4 patched talkgroups were DPD D1 NW, DPD D4 SW, DPD D4 TAC & BLUE SW.

Yes, I was monitoring both D1 & D4 at the time.

I guess what threw me off the scent, was that the duplicate clips were both listed as "DPD | D4 - Southwest - Dispatch" on the web interface.

Looking at the archive, there isn't any traffic on "DPD | D1 - Northwest - Dispatch" during that time period (23:00-23:23 on 2015-10-23).


So, perhaps there's a 'bug' in the code that copy/pastes the audio clips into the various patched talkgroups when there are 4 talkgroups in the patch?

Just trying to help debug this, not suggesting anything needs to be done, though.

Thanks again for the service.

Josh

jbeen
Posts: 11
Joined: Fri Jul 03, 2015 2:54 am

Re: Patched Channels

Post by jbeen » Sun Oct 25, 2015 4:52 am

OK, following up again.....

On Sunday morning, 2015-10-25, DPD-District 1 was patched with Blue SW for an operation with Lakewood, starting at 02:21:06.
(the patch was initially with MetroNet, but then moved to Blue SW.)
(You'll notice duplicate audio in the District 1 feed starting at 02:21.)

Then, the D1 channel went silent at 02:53:31 with no new audio displayed until 04:26:59.
This was despite there being traffic on Blue SW (monitored elsewhere).
(All District 1 traffic not related to this operation was moved to DPD D1-TAC.)

This 'missing audio' can be observed in the DPD-D1 "Call History" page.

So, I think this follows the theory that the audio for the patched calls is not getting distributed to the respective talkgroups as desired/expected. Instead, it is being copied multiple times to one of the talkgroups and not to the other(s). (my guess, anyway.)

Hope that info is helpful. :-)

Regards,
Josh

f0urtyfive
Site Admin
Posts: 35
Joined: Sun Jul 08, 2012 1:50 am

Re: Patched Channels

Post by f0urtyfive » Wed Nov 11, 2015 3:56 pm

Thanks for the Feedback Josh, I'll try to take a look soon... Probably what is a bit more likely is just a completely re-write of the web interface.

Post Reply